Configuration of phones by Snomtastic

Jan 16, 2012 at 7:00 AM

Hello!

 

First I want to thank you the authors for this Software. After investigating in Source Code, Discussions and Sniffing on the Network Level the HTTP-Requests and Answers of Snomtastic I am happy to reach the status, that 98% is working. Sometimes it would have been faster, if I would have followed your Admin-Guide word-by-word, than doing own interpredations. ;-)

 

So I have now three questions left to the community, maybe somebody can answer to me:

1.) Do the variables <$http_user> and <$http_pass> work and where will it get the login/passwords from? I thought it's taking over from global Snomtastic-Configuration, but the phone is telling no http-credentials are set

2.) I helped myself now by setting up a login and password for the http-access hard into the configuration. When I login to the phone, I am recommended to change the Login/password and Admin password from the "default value" to anything else, but I have configured something different and this is already active. I can press there the button "Press to ignore the warning forever" manually, but is there as well a way to configure the phone, that this warning never appears again? (Maybe I need to contact the Snom-Support for this question)

3.) How do you configure your phones for the OCS or Lync with Snomtastic? I have usually to set the Options user_presence_buddy_list_uri, user_pname and user_pass. The user_pname I need to set up a configuration per Domain and concat the $sAMAccountName behind, the user_pass I set the $password for, but how or where do you get the SIP-URI for user_presence_buddy_list_uri from? I want to avoid to create one configuration per each phone, because for me this makes no sense. Or what do you configure for Snom-Phones with OCS or Lync and Snomtastic?

 

Thank you very much in advance

Regards

Christian

Apr 20, 2012 at 5:38 PM
Edited Apr 20, 2012 at 5:41 PM

You have to set http_pass to the value of <$password> for it to register correctly. Also make sure that all your settings have the same index for identity 1, probably 1.